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1. Introduction 

1.1. Overview 

The Location Test System (LTS) is a configuration of the Spirent 8100 Mobile Device Test 
System. LTS provides a fully integrated test solution that enables comprehensive 
performance analysis of A-GNSS chipsets and A-GNSS enabled mobile devices. LTS 
emulates Global Navigation Satellite Systems such as the Global Positioning System 
(GPS) and the GLObal'naya NAvigatsionnaya Sputnikovaya Sistema (GLONASS), along 
with the cellular networks involved in delivery of mobile location-based services. The 
system allows you to test A-GNSS-enabled mobile devices in the lab, helping to reduce 
the time and cost of service deployments in real networks. 

LTS functionality is now categorized into four different platform configurations: 

1. 8100-A400: This platform supports LTS-ADS (A-GPS Development System); used to 
test A-GPS chipsets and modules before they are fully integrated into a wireless 
device. This system consists of a desktop PC and Spirent GPS Simulator. The A400 
platform supports the STR4500, GSS6560, GSS6700, and GSS8000 Simulators. The 
ADS Software Development Kit (ADS-SDK) is provided to develop the custom 
interface for the Device under Test. 

2. 8100-A500: This is Spirent’s flagship A-GPS test configuration used to test  
A-GPS-enabled mobile devices. The A500 configuration is a validated test platform 
for GCF and PTCRB requirements. The platform includes several instruments featuring 
the Spirent SR3420 Wireless Network Emulator and GSS6560 GPS Simulator. The 
A500 platform supports GSS6560, GSS6700, and GSS8000 Simulators. 

3. 8100-A500 (OTA): This platform supports Over-the-Air GPS testing. It supports the 
RF cable connections through TCU, and can extend the GPS power level dynamic 
range of LTS system. With SR8068 TCU, it also supports automatic cabling between 
the conducted tests and the OTA tests. 

4. 8100-A600: This platform includes all of the functionality in A500, plus equipment 
capable to run the UMTS Data Performance Module and UMTS Call Reliability 
Module. 

5. 8100-A750: This scaled-down configuration can be used for a variety of testing 
needs. This includes Over-the-Air GPS testing, Signaling Conformance, and RF 
Performance testing. The A750 platform supports the Spirent STR4500, GSS6560, 
GSS6700, and GSS8000 simulators. 

6. 8100-B Series: This platform includes LTE LBS functionality. The platform includes 
several instruments including the SR3420 Wireless Network Emulator, E2010s LTE 
Network Emulator, and the SR3452/3462 CDMA and GPS Simulator. It supports LTE 
LBS, OTDOA 2 cell and 3 cell tests, and TTCN SUPL2 tests over LTE and CDMA. 
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TestDrive Test Executive Software is included in all LTS configurations. The software 
automates A-GPS testing by fully configuring the instruments in the system, stepping 
through the test sequences, processing, and storing the results.  

By removing much of the burden of manual test set up and configuration, LTS solves the 
following testing issues: 

• Selecting the correct instruments and necessary system hardware. 

• Writing software to automate test sequences. 

• Logging test results. 

• Replication of test conditions. 

LTS allows wireless service providers, equipment manufacturers, and developers to 
evaluate A-GPS-enabled products relative to industry standards and user-defined test 
conditions. 

LTS supports industry standard test cases, as well as custom test cases developed by 
Spirent.  

As of the current release, LTS supports the following industry standard test cases: 

• 3GPP TS 34.171 A-GPS Terminal Conformance Specification 

• 3GPP TS 34.172 A-GNSS Terminal Conformance Specification 

• OMA Enabler Test Specification for SUPL v1.0 

• OMA Enabler Test Specification for SUPL v2.0 

• 3GPP TS 34.123 Protocol Conformance Specification (Section 17.2) 

• 3GPP TS 51.010 Mobile Station Conformance Specification (Section 70.7, 70.8, 70.9, 
and 70.11). 

• CTIA OTA 

• 3GPP 37.571-1 Section 7 AGPS Minimum Performance Test Cases 

• 3GPP 37.571-1 Section 9 OTDOA Minimum Performance Test Cases 

Detailed information about industry standard test cases can be found in the "LTE Test 
Case and Parameter reference manual." 
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1.2. Applications 

LTS yields thorough testing of the position location technology incorporated into A-GNSS 
mobile devices in a laboratory environment. This ensures accurate and repeatable test 
results, allowing for performance problems to be detected, isolated, and corrected in the 
shortest possible time. LTS eliminates the need for expensive, labor-intensive internally-
created test systems and can drastically reduce the time spent performing field tests 
whose conditions cannot be controlled or repeated.  

LTS includes the following applications: 

• Product Development 

• Design Verification Test 

• Quality Assurance 

• Product Evaluation 

• Interoperability Test 

• A-GPS RF Conformance Test 

• A-GPS Signaling Conformance Test 

• SUPL v1.0 Conformance Test 

• SUPL v2.0 Conformance Test 

• A-GPS Over-the-air (OTA) Test 

• OTDOA Minimum Performance Test 

1.3. Theory of Operation 

LTS is a complete, integrated system for evaluating the performance of location-capable 
GSM, W-CDMA, and LTE user equipment. This system includes all the test instruments 
and control software required to accurately emulate the bi-directional end-to-end 
connection between the SMLC and UE. The signaling protocols and air interface 
specifications between these two network entities are defined in 3GPP and OMA industry 
standards. 

Figure 1-1 contains a block diagram of the Spirent LTS system. LTS includes a desktop PC 
known as the “System Controller”, which includes most of the software required to drive 
the system. At the heart of the System Controller is the TestDrive Test Executive 
Software. TestDrive is responsible for configuring all of the instruments, sequencing test 
conditions, analyzing and storing results, and printing reports. The Spirent SMLC 
Emulator (SSE) stimulates position fixes and performs position calculation capabilities 
for MS-Assisted test modes. The SSE supports RRLP , RRC, and LPP protocols. SimGEN 
software allows you to create sophisticated GPS or GLONASS or GPS + GLONASS 
conditions and controls the Spirent GPS simulator in real-time. (Some LTS system 
platforms may use SimPLEX45 as the GPS software, and the STR4500 as the GPS 
simulator).  



4 | LTS User Manual 

The GSS6700 also works with SimREPLAYplus software. The GLONASS capability is 
available on the GSS8000 and GSS6700 only. The AirAccess HS software initializes and 
controls the SR3420 Wireless Network Emulator.   

LTS includes a number of complex instruments to execute test cases. The SR3420 
Wireless Network Emulator emulates air-interface conditions for both WCDMA and GSM 
control plane test conditions.  

LTS supports several different Spirent GNSS Simulators. The STR4500 simulator provides 
12 channels of GPS capability with playback capability only. The GSS6560 is a mid-
range simulator that provides additional capability for creating your own GPS scenarios. 
The GSS8000 is a high-end instrument with capability for multiple satellite technologies 
including GPS, GLONASS, QZSS, and Galileo. As of the LTS 5.0 release, only A-GPS and 
A-GLONASS functionality is supported by the existing test cases. 

The A500 platform configuration supports additional equipment to meet 3GPP 
conformance requirements. The TAS5048 Test Configuration Unit provides automatic 
combining, filtering, and connection of the various instruments to the UE under test. A 
power meter is utilized to perform highly accurate power level calibration of the system. 

 
Figure 1-1: LTS System Configuration Diagram 
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Figure 1-2 shows a block diagram of the Spirent LTS-ADS system. A customizable 
component known as the ADS Router, routes messages between the TestDrive software 
and the Device under Test (DUT). Spirent ADS Router SDK delivers a suite of tools to 
build and test the ADS Router. A timer/counter card and other accessories are also 
included in the system, giving you the capability to provide accurate GPS coarse-time 
and fine-time assistance to the DUT. 

 
Figure 1-2: Spirent LTS-ADS System 
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Figure 1-3 contains a block diagram of the Spirent LTS-OTA system. The OTA system 
configuration provides an interface between LTS and 3rd-party solution providers to 
perform A-GPS OTA testing. Currently, LTS is officially supported by ETS-Lindgren 
EMQuestTM software and Satimo SAM2TM software. 

 
Figure 1-3: Spirent LTS-OTA System 

LTS allows you to test the measurement performance and protocol conformance of A-
GPS-capable phones over a variety of protocols and transport layers including: 

• RRLP over GSM control plane. 

• RRC over W-CDMA control plane. 

• PreSUPL over GSM and W-CDMA user plane. 

• SUPLv1.0 GSM and W-CDMA user plane. 

• SUPLv2.0 over GSM, WCDMA and LTE user plane. 

TestDrive software also allows you to configure a variety of call flows including Mobile-
Originated Location Requests (MO-LR), Network-Induced Location Requests (NI-LR), and 
Mobile-Terminated Location Requests (MT-LR). The TestDrive Location Services Engine 
supports UE-assisted and UE-based location services. 



2. Using TestDrive LTS 

2.1. Overview 

This chapter provides an introduction to the basic steps required to successfully 
operate TestDrive LTS.  

This includes the following steps: 

• Starting TestDrive LTS. 

• Configuring Instruments. 

• Configuring User Equipment Parameters. 

• Loading a Pre-defined Test Suite. 

• Running a Test Suite. 

• Viewing Test Results. 

• Generating a Report. 

2.2. Starting TestDrive 

To open TestDrive, select Start>Programs and click the TestDrive LTS icon  
shown in the TestDrive Programs menu. The TestDrive LTS Main Window is shown 
in Figure 2-1. 

 
Figure 2-1: TestDrive LTS Main Window 
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2.2.1. Supplying a Password 

A security key connected to the parallel port or USB port on the controller PC 
protects certain features of TestDrive. Up to two unique passwords may be 
provided with your TestDrive software. To enter the passwords, select 
Configure>Password and enter the appropriate passwords, as shown in Figure 
2-2.  

NOTE: If you have been supplied with one password, leave Password 2 blank. 
If you have been supplied with one Trial Password, leave Trial Password 2 
blank. 

 
Figure 2-2: Configure Password Window 

Click Verify to confirm the password. Figure 2-3 shows the Configure Password 
Confirmation window indicating which features are unlocked. 



Chapter Two: Using TestDrive LTS | 9 

 
Figure 2-3: Configure Password Confirmation Window 

2.3. Configuring Instruments 

Prior to executing tests, you must configure information about the instruments 
currently installed in the LTS system. To configure instrument information, select 
Configure>Instruments. The Instrument Configuration window displays, as 
shown in Figure 2-4. 
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Figure 2-4: Instrument Configuration Window 

The Instrument Configuration window features are described below: 

Check Boxes – Click the box next to the specified instrument to enable or 
disable communications with the associated instrument. 

Address – Adjust the Address field to match the GPIB or IP address setting on 
the installed instruments. After installing TestDrive, the default instrument 
addresses are supplied in this dialog. To set the Spirent User Plane Application 
Services to a different port number, use the format “192.168.0.35:xxxx”, where 
xxxx = the new port #. 

Show Connection – Clicking this button displays the connection diagram for 
current configuration, as shown in Figure 2-5. 

Hide – Hides the connection diagram for current configuration. 
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Test – Tests communications with all instruments which are currently enabled. If 
communications are successfully established, a green check displays in the 
Verified column; if communications fail, a red X displays in the Verified column. 

Details – Shows details about enabled instruments such as software version, 
installed options, etc. 

OK – Saves any changes made and stores them in the system registry. 

Cancel – Cancels any changes and closes the window. 

 
Figure 2-5: Instrument Configuration Window with Connection Diagram 

The Instrument Configuration window allows you to select three types of Test 
Configuration Units, as shown in Figure 2-6. According to the selected 
configuration, the following Test Configuration Units are supported: 

• 8100-A500: SR5048 or SR8068 

• 8100-A500(OTA): SR5048 or SR8068 

• 8100-A600: SR5048 

• 8100-B Series: SR8068 or SR8048+SR8068 Combination 
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Figure 2-6: Available Test Configuration Units 

 
Figure 2-7: Configuration Tips Window – Cable Connections 
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2.4. Configuring the User Equipment (UE) Settings 

To properly execute tests, TestDrive needs information about the User Equipment 
(UE). This information is stored in a UE file (in XML format) with a .ue extension.  

To create a new UE file, select File>New>User Equipment. The New UE File 
window displays, as shown in Figure 2-8. 

 
Figure 2-8: New UE File Window 

TestDrive uses the settings in this file to setup certain UE-specific information in 
the test equipment. We recommend you create a unique UE file for each type of 
UE to be tested. The information entered into this window should reflect the 
features supported by the UE or Device under Test. 

To save the UE file, select File>Save. If you have not named the file, TestDrive 
displays the Save User Equipment File window, shown in Figure 2-9. 
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Figure 2-9: Save User Equipment File Window 

Enter a file name and click the Save button to save the file. 

2.5. Loading a Pre-defined Test Suite 

Load a pre-defined Test Suite by clicking the Open Suite icon  from the 
toolbar, or by selecting File>Open>Suite. The Open Suite window displays, as 
shown in Figure 2-10. 

 
Figure 2-10: Open Suite Window 
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Figure 2-11 shows a sample Test Suite window. 

 
Figure 2-11: Test Suite Window 

The Suite loads and the Test Suite window displays, as shown in Figure 2-11.  

The Test Suite window is split into three viewing areas: Tests, Parameters, and 
Parameter Groups. The Tests area at the top of the window shows the list of 
tests. The selected test is highlighted in blue. Select a test to display its 
parameters. The Parameters area at the bottom-right of the window shows the 
parameters for the selected test. The Parameter Group area at the bottom-left of 
the window shows the parameter groups. Select a group to display its 
parameters. 

2.6. Running a Test Suite 

Run the Test Suite by selecting the Run icon  from the toolbar or by selecting 
Execute> Run. The Execute Automatic Test window displays, as shown in Figure 
2-12. This window allows you to set several run specific options. 
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Figure 2-12: Execute Automatic Test Window 

The features available in the Execute Automatic Test window are described 
below: 

Results Name – Select a recently used database file from the drop down box, or 
click the Browse button to create a new database or select an existing one. Use 
the radio buttons below the field to append the new results to the database or 
clear the database prior to test execution. 

Run Description – TestDrive checks the database and provides a reasonable 
default value. To change it, click the text box and make the changes. This value 
is used later to view the results of the suite execution. 

Device Description – A description of the device being tested. Entering a 
description into this field makes it easier to search results. 

User Equipment File – TestDrive needs detailed information about the UE to 
present service it can acquire and successfully establish a call. Use the drop 
down box for a list of recently used files or click the Browse button to use an 
existing UE file. 

Operator Name – Enter the operator name or initials. The name is logged along 
with the results and will appear on the suite report. 
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Air-interface Configuration –TestDrive supports two methods for configuring 
basic Air-interface parameters: 

1. Use test case parameters: When this option is enabled, TestDrive loads the 
Air-interface parameters from each test case during execution. This setting 
allows the most flexibility because different Air-interface configurations can 
be tested within a single test suite execution. 

2. Use these settings for all tests: When this option is enabled, TestDrive 
overrides the local air-interface parameters with the global parameters 
specified in this window. 

Currently, the available options for Technology are GSM/GPRS, WCDMA, and 
LTE. Available operating bands display based on the selected technology. 

In some cases, the global air-interface settings may not match the capabilities of 
the selected test cases. In this case, a Warning window displays in the TestDrive 
Event Log, and the incompatible test cases are skipped. 

Text Execution –Execute every test in the suite by selecting the Execute all tests 
option. If you have selected one or more tests in the suite, you can execute only 
those selected tests by selecting the Execute selected tests only option.  

When you have finished setting the parameters in the Execute Automatic Test 
window, click Run to proceed with execution. To abort the execution, select 
Cancel. When you click Run, TestDrive displays the Results window. This window 
updates as the execution progresses. 

2.7. Viewing Test Results 

The Test Results Summary at the top of the window shows the results as each 
test completes. The current test results display on the last line of the grid. A test 
that results in a “Pass” status indicates the test was executed successfully and 
the measurement meets or exceeds the minimum performance criteria. A test 
that results in a “Fail” status has executed properly but the measurement does 
not meet the minimum performance criteria. A test results in an “Undetermined” 
status if it could not be successfully completed. Undetermined tests usually have 
errors in the Event Log associated with them. 

The bottom of the window shows the Event Log. This updates with information 
and errors as suite execution progresses. When a test is selected from the grid, 
the corresponding graph, detail results, and/or the range of the result display, if 
applicable. 
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Figure 2-13: Test Suite Window–Results 

2.8. Generating a Report 

To generate a report, click the Generate Report  button or select 
Execute>Generate Report while the Results window is active. Select single or 
multiple test results by pressing CTRL+Left-click or SHIFT+Left-Click. Right-click 
to generate a report for all tests or for selected tests only. 

 
Figure 2-14: Report Window 
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Figure 2-15: Generate Report Window 

The following is a description of the features available while viewing a report: 

Save  – Saves the report in Acrobat PDF format and other popular document 
formats. You can also access the Save command by selecting File>Save/Save 
As. You can view a saved report with the associated software at a later time. 

Print – Prints the report to the default printer. 

Zoom – Adjusts the scale of the display to allow an entire page to displayed or 
a fraction of a page. 

Jump to first page  – Jumps to the first page of the report. 

Previous page  – Jumps to the previous page of the report. 

Next page – Jumps to the next page of the report. 

Jump to last page – Jumps to the last page of the report. 

Go to page  – Jumps to any specific page. 

Refresh – Refreshes the display of the report. 
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2.8.1. Report Options Configuration 

The reports are divided in different sections. Each section can be configured to 
display in the report. This allows the generation of specific parts of the report, 
without the need to generate the full report. To configure the report options, 
select Configure>Report Options. The Report Configuration window displays, as 
shown in Figure 2-16. 

 
Figure 2-16: Report Options Configuration Window 

Select the report options to include in the report and deselect the unwanted 
options. Click the OK button to confirm the changes. Any report generated after 
configuring the report options contains only the selected sections. This 
configuration only affects the generation of new reports. It does not affect any 
existing reports.



3. Advanced Features 

3.1. Overview 

This chapter provides a detailed description of the TestDrive LTS Test Executive. The 
TestDrive user-interface is divided into the following items:  

• Main Menu 

• Toolbar 

• Document Viewer 

• Document Window 

• Status Bar 

• Progress Bar 

Figure 3-1 shows a sample of the Test Executive window. Each of the items above are 
described in detail in the following sections. 

The TestDrive Test Executive supports four main document types including:  

1. Test Suites 

2. User Equipment information 

3. Test Results 

4. Reports 

A Test Suite is a file containing all information related to executing a sequence of pre-
defined tests. You can edit these files to define custom test sequences. A User 
Equipment file contains information which is relevant to a specific UE. This includes 
information such as the UE mobile country code (MCC) and mobile network code (MNC). 
The Test Results window displays parametric results generated during test execution. 
TestDrive only allows you to view the results of a single suite execution at any time. Test 
Reports display formatted information about a particular set of test results. These 
documents can be saved in various document formats or printed. Specific details about 
using these various document types are described in this chapter. 

The features available on the main menu and toolbar are context-sensitive. Certain 
features may or may not be available depending on which document is currently active 
in the document window. For example, the Run button is disabled if a Report is active, 
since you would not run a report. An active document is the document which is currently 
visible in the document window. 
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Figure 3-1: TestDrive Test Executive Window 

3.1.1. File Cabinet 

The file cabinet in TestDrive LTS simplifies the management of suite, UE, result, and 
report files. All files that are stored within the default TestDrive directory structure are 
accessible from the file cabinet. You can open or delete Suite files, UE files, SSE 
Configurations, Suite Results, and Report .pdf files from this window. 

To open any document, double-click on the item or right-click and select Open on the 
drop-down menu. When opening a database, you may see multiple sets of results. 
Double-click on a particular result to load it from the database. To delete a document, 
right-click and select Delete from the drop-down menu. 

 
Figure 3-2: TestDrive File Cabinet Window 
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3.2. Test Suites 

Test Suites are the main document type used to create, modify, and execute sequences 
of custom-defined tests. There are two main sections in a Suite document: the Tests 
section at the top of the screen includes the list of tests to execute; the Test Parameters 
section at the bottom of the screen displays the test parameters for a selected test. 
Figure 3-3 shows a sample Test Suite window. 

 
Figure 3-3: Test Suite Window 

3.2.1. Suite File Management 

All test suites are stored in XML file format. TestDrive provides the ability to create new 
suites, open existing suites, and save edited suites. A description of each of these 
features is provided below: 

 New — Creates a new test suite. You can also access this feature by selecting 
File>New. 

 Open — Opens an existing test suite. You are prompted to select from a list of 
suites in the default test suite directory. You can also access this feature by selecting 
File>Open. 

  Save — Saves the currently active test suite. You can also access this feature 
by selecting File>Save/Save As. 

TestDrive does not impose any limits on the number of test suites that can be loaded at 
any given time. However, you can only execute one test suite at a time. If more than one 
test suite is loaded, TestDrive executes the currently active test suite when you click the 
Run button .  
Refer to Section 4.1 on page 20 for a definition of active document. 
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3.2.2. Editing a New Test Suite 

The LTS file cabinet provides the easiest way to create new test suites. Select the test 
suite you want to add from the file cabinet, and move it into the test suite editor, as 
shown in Figure 3-4. You can move as many suites as needed to create a larger test 
suite. 

 
Figure 3-4: LTS File Cabinet 

3.2.3. Adding a New Test 

This section describes an alternative method for creating new test suites. Each line in a 
test suite can be one of several different test types. Different tests are used to measure 
different performance criteria. A unique set of parameters applies to each test type. Refer 
to Chapter 5 for a detailed description of all supported test types. 

To select a test type when adding a new test: 

1. Click on a blank cell in the Test Name column of the Suite window. 

2. Right-click the cell to display the Insert Test menu. 

3. Select the desired test from the menus. 

Figure 3-5 below illustrates an example of adding a new GPS Circular Motion Test to a 
test suite. 

 
Figure 3-5: Test Suite Window – Tests 

NOTE: Once a test is selected for a particular row, it cannot be changed. Delete the 
test to make the cell blank and then use the steps above to create a new test. 
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3.2.4. Editing Test Parameters 

Each test supported by TestDrive includes a number of customizable test parameters. 
Test parameters can be numerical values (e.g. Number of Calls), text values (e.g. Test 
Description), or a list of selectable values (e.g. Operating Band).  

To change the value of a particular test parameter: 

1. Click a specific line in the Tests pane to select the test. 

2. Select the parameter sub-group in the tree view on the left side of the Test 
Parameters pane. 

3. Click the parameter you want to edit and type or select a new value. 

Test parameters displayed in blue indicate that the parameter is a read-only value. 
Parameters displayed in gray indicate that the parameter may be disabled as a function 
of another parameter setting within the specified test (e.g. User Plane Protocol does not 
apply if the Transport is set to “Control Plane”). 

Figure 3-6 shows an example of selecting a new Transport from the LBS Parameters sub-
group of the GPS Circular Motion test. 

 
Figure 3-6: Selecting a New Transport from the LBS Parameters 

3.2.5. Modifying Test Sequences 

To simplify the task of modifying test sequences, TestDrive provides the capability to cut, 
copy, paste, and delete tests within any loaded test suites.  

 Cut — Cuts a specific test or list of tests from a specified test suite. You can also 
access this feature by selecting Edit> Cut, or by the keyboard shortcut Ctrl + X. 

 Copy — Copies a specific test or list of tests from a specified test suite. You can also 
access this feature by selecting Edit >Copy, or by the keyboard shortcut Ctrl + C. 

 Paste — Pastes a test or list of tests to a location within a given test suite. Note that 
tests can be pasted to any test suite which is currently loaded into the application. You 
can also access this feature by selecting Edit>Paste, or by the keyboard shortcut Ctrl + 
V. 
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 Delete — Deletes a test or list of tests from a test suite. You can also access this 
feature by selecting Edit>Delete menu, or by the keyboard shortcut Del. 

To cut, copy, or delete a list of tests, you must press the Shift or Ctrl keys, and then click 
a continuous or selective set of tests within a suite. It is also possible to hold the Shift 
key down, and press the up/down arrow keys or page up/down keys to select blocks of 
continuous tests. 

3.2.6. Group Edit 

Group Edit allows you to set a parameter to the same value in more than one test without 
editing each test individually. For example, Group Edit would make the task of setting 
the GSM Downlink Power to –90 dBm for tests 2 through 4 an easy one. 

TestDrive allows you to select more than one test at a time. Click the first test of the 
group you want to select. Hold down the Shift key and click on the last test in the group. 
You can also select tests by holding down the Ctrl key and clicking on the individual 
tests you want to edit. The tests selected do not need to be in a contiguous block when 
selections are made in this manner. 

 
Figure 3-7: Selecting a Test Group 

Once you have your group of tests selected, you can make changes to the test 
parameters. If you set a parameter, it affects that parameter in every test in the group to 
the value you enter. Some parameters may not apply to every test selected. In this case, 
TestDrive displays a window indicating this condition and the parameter setting only 
applies to those tests that support the parameter. 

3.2.7. Validating a Test Suite 

Tests should be validated before running a Test Suite to help avoid test execution errors. 
TestDrive can analyze an entire suite for test setup and parameter value problems before 
execution. Validation checks test conditions against the current system configuration 
and alerts you if the system does not contain sufficient hardware to perform certain 
tests. Although this does not guarantee flawless execution, it significantly reduces the 
risk of problems during execution by detecting them beforehand.  

To validate the Test Suite click the Validate Suite icon  from the Toolbar or select 
Execute>Validate. The Test Suite Validation window displays, as shown in Figure 3-8. 
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Figure 3-8: Test Suite Validation Window 

Select the User Equipment File for suite execution. The information in this file is critical 
for correct validation of the suite. You can select either the Validate All Tests or Validate 
Selected Tests option under Test Validation. 

When validation is complete, TestDrive displays a results window similar to the results 
window displayed during suite execution. If any warnings or errors are detected, they 
display in the Event Log. Otherwise the message “Validation completed: no errors” 
displays. Note that the validation procedure is automatically executed every time a test 
suite is started. 

3.3. User Equipment Files 

User Equipment (UE) Files specify UE-specific criteria which may be necessary for a 
particular UE to acquire service and establish calls. All UE Files are stored in XML file 
formats. TestDrive provides the ability to create new UE files, open existing UE files, and 
save edited UE files.  

A description of each of these features is provided below: 

 New — To create a new UE file, click the arrow to the right of the icon and select 
New User Equipment from the drop-down menu. You can also access this feature by 
selecting File>New. 

 Open — To open an existing UE file, click the arrow to the right of the icon and 
select Open User Equipment from the drop-down menu. You are prompted to select 
from a list of UE files in the default User Equipment directory. You can also access this 
feature by selecting File>Open. 

 Save — Saves the currently active UE file. You can also access this feature by 
selecting File>Save. 
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A sample UE window is shown in Figure 3-9.  

A UE file consists of seven key groups of data including:  

1. Air Interface Technology  

2. Network Settings 

3. Authentication 

4. RF Characteristics 

5. Custom Instrument Commands 

6. UE Automation 

7. Supported SUPL Options 

Each of these information types are described in the following sections. 

 
Figure 3-9: UE File Window 

3.3.1. Air Interface Technology 

The technologies supported by the Device under Test are specified here. If the platform 
selected is A400, this parameter will be disabled. 
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3.3.2. Network Settings 

The Network Settings in the UE file are critical for successful service acquisition and call 
setup. If TestDrive consistently fails to setup a call with the UE, the UE parameters 
should be adjusted. The following is a brief description of network settings in this file: 

Mobile Country Code (MCC) — The mobile country code of the Unit under Test. If this 
value is incorrect, the UE may not be able to acquire service. 

Mobile Network Code (MNC) — The mobile network code of the Unit under Test. If this 
value is incorrect, the UE may not be able to acquire service.  

3.3.3. Authentication 

The authentication settings in the UE file allow you to enable or disable authentication 
and security procedures during UE registration and call setup. You can also specify an 
authentication key matching the SIM card settings.  

3.3.4. RF Characteristics 

The RF characteristics define the path loss information between the LTS system and the 
Device under Test. 

GPS RF Port Configuration — The port through which the GPS signal will be fed into the 
UE. The UE either has separate ports for the GSM and GPS signals or a single combined 
port for the two signal types. 

Insertion Loss Settings — The Insertion Loss section of the UE file allows you to specify 
the amount of external cabling loss between the Spirent LTS system and the Unit under 
Test. Figure 3-10 illustrates a typical connection between LTS and a UE. To achieve the 
most accurate power level, it is important that the UE file contains accurate information 
about the insertion loss of any external cabling. Because loss can vary with frequency, 
TestDrive allows you to enter insertion loss for user-defined frequencies. 

Spirent
LTS

UEExternal
Cabling

 
Figure 3-10: Diagram of External Cabling 

The connection between LTS and the UE typically consists of a single RF cable plus some 
additional adapters. However, it is possible (though not recommended) to connect 
additional components such as an RF splitter or coupler. In this case, the insertion loss 
in the uplink and downlink may not be uniform. TestDrive allows for this possibility by 
allowing you to specify separate insertion loss values for uplink and downlink paths. 
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To edit a value in the table, click on the appropriate cell. That cell becomes a text box. 
Edit the value as you would in a standard text box. When you are finished editing the 
value, click Enter. To add new rows to the table, click the InsertionLoss button and add 
the appropriate contents. A row must have at least a frequency and a loss value. 

NOTE: The Spirent LTS system is calibrated to the end of cables labeled Spirent LTS 
C2 and Spirent LTS C18. 

TestDrive implements a simple linear interpolation algorithm to determine the cable loss 
at unspecified frequencies. For example, suppose the insertion loss in the downlink is 
specified in the table below.  

Frequency Insertion Loss 

2000.0 1.5 

2100.0 1.8 

2200.0 2.2 

The estimated insertion loss vs. frequency is derived from the line segments depicted on 
the graph shown in Figure 3-11.  

 
Figure 3-11: Estimated Loss vs. Frequency Graph 

3.3.5. Supported Positioning Technologies and Methods 

Various options are provided to indicate the types of positioning technologies and 
protocols the UE supports. This information is used by TestDrive for SUPL Conformance 
Tests. 
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3.3.6. UE Automation Support 

 
Figure 3-12: UE Automation Window 

The UE Automation window, shown in Figure 3-12 allows you to input customer-defined 
AT Command strings to control the UE. You can also set UTS to control the UE. This is 
used by the LTS system during test execution. 

3.3.6.1 AT Command Support 

Usually, during test case execution, LTS displays a window notifying you that the system 
needs assistance to continue the test. If AT command support is enabled, TestDrive 
attempts to automate this function through the UE diagnostic port, and this window 
does not display on the GUI. This may require installation of special drivers to 
communicate with the DUT. 

There are nine AT commands used by LTS, as shown in Figure 3-13. Refer to the AT 
Command Parameter Description for details. A simple testing tool is given in the AT 
Command window to complete basic verification before beginning test execution. 
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Figure 3-13: UE Automation Window – AT Commands 

 — The Enable AT Command option allows you to automate the user-
assisted portions of the legacy LTS tests, such as 34.171 or 51.010. 
The Port setting allows you to select the corresponding port connected to the UE being 
tested. 
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AT Command Parameters Details Description 

Reset UE: 
This parameter specifies the AT command string to reset UE.  
When you create a new UE file, LTS will give the default value of "AT+CFUN=1,1" 

Originate a voice call: 
This parameter specifies the AT command string to make UE originate a voice call 
The default value is "ATD", and LTS will append the dial number to this sting according the test 
parameter’s settings in the runtime. 

Answer a voice call:  
This parameter specifies the AT command string to make UE answer to incoming voice call 
The default value is "ATA". 

Originate a MO-LR session for Assistance Data (Control plane only):  
This parameter specifies the AT command string to make UE to start a MOLR in control plane 
which the location type is requesting for assistance data.  
This command is experimental and there is no default value for this command given by LTS. 

Originate a MO-LR session for Location Estimate (Control plane only):  
This parameter specifies the AT command string to make UE to start a MOLR in control plane 
which the location type is location estimate.  
This command is experimental and there is no default value for this command given by LTS. 

Originate a Set-Initiated Location Request (SUPL only):  
This parameter specifies the AT command string to make UE to start a SET initiated session in 
user plane.  
This command is experimental and there is no default value for this command given by LTS. 

Retrieve handset location:  
This parameter is reserved for future use. 

Accept Privacy Notification:  
This parameter specifies the AT command string to make UE to accept a Privacy Notification sent 
by LTS. 
This command is experimental and there is no default value for this command given by LTS. 

Deny Privacy Notification:  
This parameter specifies the AT command string to make UE to deny a Privacy Notification sent by 
LTS.  
This command is experimental and there is no default value for this command given by LTS. 

Reset UE Positioning Stored Info: 
This parameter specifies the AT command string that resets the positioning assistance data 
information inside the UE. 
NOTE: This command is experimental and there is no default value for this command given by 
LTS. 
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3.3.6.2 UTS Support 

The UTS Window shown in Figure 3-14 allows you to set the UTS interface to control the 
UE. This is used by LTS system during standalone GPS test execution. 

When you set the UE Automation Type to UTS, there are two buttons enabled. The "Find 
UTS Driver" button allows you to find all of the UTS drivers available on your PC. You can 
then select the appropriate UE driver from the list. The "Test UTS Connection" button 
allows you to test the settings. 

 
Figure 3-14: UTS Settings 

3.4. Spirent SMLC Emulator (SSE) 

The Spirent SMLC Emulator (SSE) is an integrated component of the LTS system that 
allows full control of all assistance data provided to a mobile device during automated 
A-GPS testing. The SSE simulates the core functionality of an actual SMLC, allowing for a 
mobile device to request and receive assistance data through standard 3GPP signaling. 
With the ability to create and store a wide range of configurations in a pre-defined file 
format, the SSE enables comprehensive coverage to the numerous message content 
possibilities. 

3.4.1. SSE Configuration 

TestDrive LTS provides a user-friendly interface for defining the assistance data message 
content provided to a mobile device during a test session. Each various assistance data 
configuration is stored in a file and can be recalled on a per-test basis. SSE Configuration 
files have an extension of .sse and can be created, recalled, and saved through the 
TestDrive LTS test executive.  

A description of each of the file features is provided below: 

 New — To create a new SSE Configuration file, click the arrow to the right of the 
icon and select New SSE Configuration from the drop-down menu. You can also access 
this feature by selecting File>New. 
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 Open — To open an existing SSE Configuration file, click the arrow to the right of 
the icon and select Open SSE Configuration from the drop-down menu. You will be 
prompted to select from a list of SSE Configuration files in the default SSE Configuration 
directory. You can also access this feature by selecting File>Open. 

 Save — Saves the currently SSE Configuration file. You can also access this feature 
by selecting File>Save. 

Upon recalling or creating a SSE Configuration file, the SSE Configuration Utility displays 
with the contents of the file. This utility provides the ability to modify the configuration of 
the SSE state machine, as well as the message content of the assistance data provided 
to the mobile Device under Test.  

 
Figure 3-15: SSE Configuration Utility 
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3.4.2. Configuration Details 

This section includes parameters that apply to the high-level configuration of the SSE, 
including details regarding the particular file as well as control of the SSE state machine. 
The following table gives a description of these parameters. 

Configuration Parameters 

Maximum Message Length 
This parameter specifies the maximum length (in bytes) of a message generated by the SSE. The 
SSE breaks apart any messages that exceed this limit into smaller messages. 

Handling of Non-Supported IEs 
This parameter defines the method for handling requests from the mobile device for Information 
Elements (IEs) supported in the specified SSE configuration. The SSE can be programmed to 
either send a “Protocol Error” message upon receiving this request or ignore the request for the 
unsupported IEs. 

Send All IEs as Separate Messages 
This parameter provides the ability to control the segmentation of the Information Elements (IEs) 
provided by the SSE. The SSE can be programmed to either send each particular IE as a separate 
message or send the minimum amount of messages by optimally segmenting the IEs to be 
delivered based on the value of the Maximum Message Length parameter. If this parameter is set 
to send all IEs as separate messages and the size of the IE exceeds the number of bytes specified 
for the Maximum Message Length parameter, the IE is broken into separate IEs accordingly. 

Include Accuracy for MS-Assisted Sessions 
This parameter provides the ability to specify whether the SSE should include Accuracy when 
conducting an MS-Assisted location session. Per 3GPP TS 04.31, this parameter is optional for 
MS-Assisted sessions. It will always be provided for MS-Based location sessions. 

Always Include GPS Assistance Data Fields in Measure Position Request 
This parameter provides the ability to specify whether the SSE should always include the GPS 
Assistance Data fields in the Measure Position Request message regardless of whether any 
assistance data is included in the message. 

Enable useMultipleSets in Measure Position Request 
This parameter provides the ability to enable and disable the useMultipleSets bit in the Measure 
Position Request message in RRLP.  
This parameter can only enabled and be used with the test parameter Analysis Type set to 
Location Measurement. 

Always include GPS assistance data of 16 satellites 
This parameter provides the ability to specify whether the SSE should always include the 16 
satellites” GPS assistance data in RRLP messages.  
This parameter can only be enabled when the LTS password supports this feature. 
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3.4.3. GPS Information Elements (IE) 

The Supported option associated with each Information Element (IE) allows you to 
program its availability. When the mobile device requests assistance data during a 
location session, the SSE provides data for each IE supported under this SSE 
configuration. If the mobile device requests an IE that is not selected as supported, the 
SSE handles this as specified by the Handling of Non-Supported IEs parameter. 

The SSE currently supports the ability to configure the content of the following 
Information Elements: 

• Reference Time 

• Reference Location 

• Acquisition Assistance 

Click the Settings button associated with these Information Elements to display the 
specific configuration options associated with the selected IE. The IE Settings window 
provides control of both Message-Level parameters and Satellite-Level Parameters. 
Message-Level parameters are parameters that only appear once within the specified 
Information Element. Satellite-Level parameters are parameters that are repeated for 
each particular Satellite ID available. Each parameter displayed maps to a particular 
parameter defined in the corresponding 3GPP Information Element. 

The IE Settings window provides control of three types of parameters: 

1. Configuration Parameter —This parameter can be optionally included in this 
Information Element. 

2. Value Parameter — The value of this parameter is constant over the execution of a 
test session. Either an explicit value can be defined or it can be automatically 
specified by the settings in the test case (by setting the value to “Auto”. 

3. Offset Parameter —The value of this parameter is changing in real-time over the 
execution of a test session. A fixed offset can be applied to the value of this 
parameter 

For Satellite-Level parameters, you can apply modifications for a particular Satellite ID to 
all satellites by clicking the Apply to All Satellites button. 
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Figure 3-16: SEE Configuration Utility – IE Settings 

3.4.4. GPS Assistance Data Coverage 

The Spirent SMLC Emulator currently supports the following RRLP Information Elements 
as defined in 3GPP TS 04.31, Release 99. 

Information Element Configurable? 

Reference Time  

Reference Location  

DGPS Corrections  

Navigation Model  

Ionospheric Model  

UTC Model  

Almanac  

Acquisition Assistance  

Real-Time Integrity  
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3.4.5. GANSS Common Assistance Data Coverage 

The Spirent SMLC Emulator currently supports the following RRLP Information Elements, 
as defined in 3GPP TS 44.031 Release 8.3; Table A.31. 

Information Element Supported? Configurable? 

GANSS Reference Time   

GANSS Reference Location   

GANSS Ionospheric Model   

GANSS Additional Ionospheric 
Model 

  

GANSS Earth Orientation Parameters   

The Spirent SMLC Emulator currently supports the following RRC Measurement Control 
Request Information Elements, as defined in 3GPP TS 25.331 Release 8.8.0. 

Information Element Supported? Configurable? 

GANSS Reference Time   

GANSS Reference Location   

GANSS Ionospheric Model   

GANSS Additional Ionospheric 
Model 

  

GANSS Earth Orientation Parameters   

3.4.6. GANSS Generic Assistance Data Coverage 

The Spirent SMLC Emulator currently supports the following RRLP Information Elements, 
as defined in 3GPP TS 44.031 Release 8.3; Table A.39. 

Information Element Supported? Configurable? 

GANSS ID   

GANSS Time Model   

DGANSS Corrections   

GANSS Navigation Model   (GANSS Orbit Model - 
Model 4, GANSS Clock Model 
- Model 4) 

 

GANSS Real-Time Integrity   

GANSS Data Bit Assistance   

GANSS Reference Measurement 
Information 

  

GANSS Almanac Model  (Model 5)  

GANSS UTC Model   
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Information Element Supported? Configurable? 

GANSS Ephemeris Extension   

GANSS Ephemeris Ext Check   

SBAS ID   

GANSS Additional UTC Model  (Model 3)  

GANSS Auxiliary Information   

The Spirent SMLC Emulator currently supports the following RRC Measurement Control 
Request Information Elements, as defined in 3GPP TS 25.331 Release 8.8.0. 

Information Element Supported? Configurable? 

GANSS ID   

GANSS Time Model   

DGANSS Corrections   

GANSS Navigation Model    

GANSS Real-Time Integrity   

GANSS Data Bit Assistance   

GANSS Reference Measurement 
Information 

  

GANSS Almanac Model  (Model 5)  

GANSS UTC Model   

GANSS Ephemeris Extension   

GANSS Ephemeris Ext Check   

SBAS ID   

GANSS Additional UTC Model  (Model 2)  

GANSS Auxiliary Information   
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3.4.7. GPS Reference Time Information Element 

The following table outlines the current availability and control of the parameters 
contained in the Reference Time Information Element provided by the SSE. 

Field Configurable? Type 

GSM Time Present  Present/Not Present 

GPS Week  Offset 

GPS TOW  Offset 

BCCH Carrier  Value 

BSIC  Value 

FNm  Offset 

TN  Offset 

BN  Offset 

GPS TOW Assist  N/A 

3.4.8. GPS Reference Location Information Element 

The following table outlines the current availability and control of the parameters 
contained in the Reference Location Information Element provided by the SSE. The SSE 
currently supports the “Ellipsoid point with altitude” shape type, as defined in 3GPP TS 
03.32. 

Field Configurable?  

Latitude X Offset 

Longitude X Offset 

Altitude X Offset 
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3.4.9. GPS Navigation Model Information Element 

The following table outlines the current availability and control of the parameters 
contained in the Navigation Model Information Element provided by the SSE. 

Field Configurable? Type 

Num_Sats_Total X No 

SatID X No 

Satellite Status X No 

C/A or P on L2 X No 

URA Index X No 

SV Health X No 

IODC X No 

L2 P Data Flag X No 

SF 1 Reserved X No 

TGD X No 

Toc X No 

af2 X No 

af1 X No 

af0 X No 

Crs X No 

∆n X No 

M0 X No 

Cuc X No 

E X No 

Cus X No 

(A)1/2 X No 

Toe X No 

Fit Interval Flag X No 

AODO X No 

Cic X No 

OMEGA0 X No 

Cis X No 

i0 X No 

Crc X No 

Ω X No 

OMEGAdot X No 

Idot X No 
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3.4.10. GPS Ionospheric Model Information Element 

The following table outlines the current availability and control of the parameters 
contained in the Ionospheric Model Information Element provided by the SSE. 

Field Configurable? Type 

α0 X No 

α1 X No 

α2 X No 

α3 X No 

β1 X No 

β2 X No 

β3 X No 

β4 X No 

3.4.11. GPS Almanac Information Element 

The following table outlines the current availability and control of the parameters 
contained in the Almanac Information Element provided by the SSE. 

Field Configurable? Type 

Num_Sats_Total X No 

WNa X No 

SatID X No 

E X No 

toa X No 

δi X No 

OMEGADOT X No 

SV Health X No 

A1/2 X No 

OMEGA0 X No 

Ω X No 

M0 X No 

af0 X No 

af1 X No 
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3.4.12. GPS Acquisition Assistance Information Element 

The following table outlines the current availability and control of the parameters 
contained in the Acquisition Assistance Information Element provided by the SSE. 

Field Configurable? Type 

Number of Satellites  No 

GPS TOW  Offset 

GSM Time Present  Present/Not Present 

BCCH Carrier  Value 

BSIC  Value 

FNm  Offset 

TN  Offset 

BN  Offset 

SVID/PRNID  No 

Doppler0  Offset 

Doppler1   

Doppler Uncertainty   

Code Phase  Offset 

Integer Code Phase  Offset 

GPS Bit Number  Offset 

Code Phase Search Window  Offset 

Azimuth*  Offset 

Elevation*  Offset 

*These presence of these parameters in this Information Element can be specified in the configuration file. 

NOTE: Disable each satellite in the IE by selecting the Removed from IE option. 

3.4.13. GANSS Reference Time Element 

The following table outlines the current availability and control of the parameters 
contained in the GANSS Reference Time Element provided by the SSE. These fields are 
defined in 3GPP TS 44.031 Release 8.3.0; Table A.33. 

Field Supported? Configurable? 

GANSS Day  X 

GANSS TOD  X 

GANSS TOD Uncertainty  X 

GANSS_TIME_ID  X 

BCCH Carrier X N/A 

BSIC X N/A 
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Field Supported? Configurable? 

FNm X N/A 

TN X N/A 

BN X N/A 

FN1 X N/A 

3.4.14. GANSS Reference Location Element 

This element contains the same fields as defined in the GPS Reference Time Element 
defined in the section above. 

3.4.15. GANSS Ionospheric Model 

The SSE currently does not support the GANSS Ionospheric Model Information Element. 

3.4.16. GANSS Additional Ionospheric Model 

The following table outlines the current availability and control of the parameters 
contained in the GANSS Additional Ionospheric Model Element Information provided by 
the SSE.  

These fields are defined in 3GPP TS 44.031 Release 8.3.0; Table A.33. 

Field Supported? Configurable? 

Data ID  X 

a0  X 

a0  X 

a0  X 

a0  X 

b0  X 

b0  X 

b0  X 

b0  X 

3.4.17. GANSS Earth Orientation Parameters 

The SSE currently does not support the GANSS Earth Orientation Parameters Information 
Element. 
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3.4.18. GANSS ID 

The following table outlines the current availability and control of the parameters 
contained in the GANSS ID Information Element provided by the SSE. These fields are 
defined in 3GPP TS 44.031 Release 8.3.0; Table A.40. 

Field Supported? Configurable? 

GANSS ID  X   (Set to 3 for GLONASS) 

3.4.19. GANSS Time Model 

The following table outlines the current availability and control of the parameters 
contained in the GANSS Time Model Information Element provided by the SSE. These 
fields are defined in 3GPP TS 44.031 Release 8.3.0; Table A.41. 

Field Supported? Configurable? 

GANSS Time Model Reference Time  X 

TA0  X 

TA1  X 

TA2  X 

GNSS_TO_ID  X  (Always set to 0 = GPS) 

Week Number  X 

3.4.20. DGANSS Corrections 

The following table outlines the current availability and control of the parameters 
contained in the DGANSS Corrections Information Element provided by the SSE. These 
fields are defined in 3GPP TS 44.031 Release 8.3.0; Table A.43. 

Field Supported? Configurable? 

DGANSS Reference Time  X 

N_SGN_TYPE  (Only 1 signal type 
currently supported) 

X   

GANSS_Signal_ID   X (Set to 3 for GLONASS)  

Status/Health  X 

N_SAT  X  

SV_ID  X 

IOD  X 

UDRE  X 

PRC  X 

RRC  X 
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3.4.21. GANSS Navigation Model 

The following table outlines the current availability and control of the parameters 
contained in the GANSS Navigation Model Information Element provided by the SSE. 
These fields are defined in 3GPP TS 44.031 Release 8.3.0; Table A.46. 

Field Supported? Configurable? 

Num_Sat  X 

Non-Broadcast Indication  X (Set to 0)   

SV ID   X  

SV Health  X 

IOD  X  

GANSS Clock Model  (Model 4 Table 
A.49.1)   

X 

GANSS Orbit Model  (Model 4 Table 
A.49.2) 

X 

SV Health_MSB  X 

IOD_MSB  X 

3.4.22. GANSS Real-Time Integrity 

The following table outlines the current availability and control of the parameters 
contained in the GANSS Real Time integrity Information Element provided by the SSE. 
These fields are defined in 3GPP TS 44.031 Release 8.3.0; Table A.50. 

Field Supported? Configurable? 

Bad_GNSS_SV_ID  X 

Bad_GNSS_Signal_ID  X    

3.4.23. GANSS Data Bit Assistance 

The SSE currently does not support the GANSS Data Bit Assistance Information Element. 

3.4.24. GANSS Reference Measurement Infomation 

The following table outlines the current availability and control of the parameters 
contained in the GANSS Reference Measurement Information by the SSE. These fields 
are defined in 3GPP TS 44.031 Release 8.3.0; Table A.52. 

Field Supported? Configurable? 

GANSS_Signal_ID  X 

SV_ID  X    

Doppler (0th order term)  X 

Doppler (1st order term)  X    
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Field Supported? Configurable? 

Doppler Uncertainty  X 

Code Phase   X    

Integer Code Phase   X 

Code Phase Search Window  X    

Azimuth  X 

Elevation  X    

3.4.25. GANSS Almanac Model 

The following table outlines the current availability and control of the parameters 
contained in the GANSS Reference Measurement Information by the SSE. These fields 
are defined in 3GPP TS 44.031 Release 8.3.0; Table A.54. 

Field Supported? Configurable? 

Num_Sats_Total  X 

Week Number  X    

Toa  X 

IODa  X    

Model-5 

NA  X    

nA  X 

HnA  X    

λnA  X 

tλnA  X    

ΔinA  X    

ΔTnA  X    

ΔT_DOTnA  X    

εnA  X    

ωnA  X    

τnA  X    

Can  X    

MnA  X    

3.4.26. GANSS UTC Model 

The SSE currently does not support the GANSS UTC Model Information Element. 



Chapter Three: Advanced Features | 49 

3.4.27. GANSS Ephemeris Extension 

The SSE currently does not support the GANSS Ephemeris Extension Information 
Element. 

3.4.28. GANSS Ephemeris Ext Check 

The SSE currently does not support the GANSS Ephemeris Ext Check Information 
Element. 

3.4.29. SBAS ID 

The SSE currently does not support the SBAS ID Information Element. 

3.4.30. GANSS Additional UTC Model 

The following table outlines the current availability and control of the parameters 
contained in the GANSS Additional UTC Model Element Information provided by the SSE. 
These fields are defined in 3GPP TS 44.031 Release 8.3.0; Model 3 of Table A.55.17 and 
3GPP TS 25.331 Release a20; Model 2 of sub-clause 10.3.7.97d. 

Field Supported? Configurable? 

NA  X 

Tc  X 

B1  X 

B2  X 

KP  X 

3.4.31. GANSS Auxillary Information  

The following table outlines the current availability and control of the parameters 
contained in the GANSS Reference Measurement Information by the SSE. These fields 
are defined in 3GPP TS 44.031 Release 8.3.0; Table A.55. 

Field Supported? Configurable? 

SV ID   X    

Channel Number  X    

Signals Available  X    
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3.4.32. GANSS Additional Navigation Model  

The SMLC only supports the GANSS Additional Navigation Model for IE RRC messages. 
The following table outlines the current availability and control of the parameters 
contained in the Additional Navigation Model provided by the SSE. These fields are 
defined in 3GPP TS 25.331 Release 8.8.0; Table A.46. 

Field Supported? Configurable? 

Non-Broadcast Indication  X (Set to 0)   

SV ID   X  

SV Health  X 

IOD  X  

GANSS  Additional Clock Model  (Model 4 of table 
10.3.7.91f)   

X 

GANSS Additional Orbit Model  (Model 4 of table 
10.3.7.91e) 

X 
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3.5. Test Results 

The Test Results window provides real-time feedback about the status of tests within a 
currently executing suite. This window also displays results of previous tests stored in a 
TestDrive database. The Test Results window is split into five main sections:  

1. Test Results Summary  

2. Status Bar  

3. Detailed Results  

4. Graphs  

5. Event Log 

The following sections describe the items above in detail. For information on how to load 
test results, refer to Section 3.6 on page 17.  

 
Figure 3-17: Test Results Window 
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3.5.1. Test Results Summary 

The Test Results Summary details pass/fail status and parametric measurements 
performed during a test suite execution. The following is a brief description of the 
columns which are always displayed in this pane: 

Test # - Represents the test number as specified in the Suite File. If you select a sub-set 
of tests to execute, then the test numbers displayed may not be sequential. 

Test Name – Displays the test type. For a detailed description of all supported tests, 
refer to Chapter 5. 

Description – Displays a detailed description of the specified test. This information is 
typically specified by the creator of the test suite. 

Status – Indicates the outcome of the test. This field is set to one of the following 
values: Pass, Fail, or Undetermined. Undetermined indicates that not enough 
information was obtained to determine whether the measurement was acceptable (e.g., 
if a call cannot be established, it may be impossible to determine whether the phone can 
pass specified performance criteria). 

In addition to these fields, each test has a unique set of test-specific results which may 
display to the right of the status column. For detailed information of test-specific results, 
refer to Chapter 5. 

3.5.2. Results Status Bar 

The status bar displays the following key statistics in real-time during test execution: 

Tests Passed – Indicates the number of tests that passed up to the current execution 
time. 

Tests Failed - Indicates the number of tests that failed up to the current execution time. 

Tests Undetermined – Indicates the number of tests which were not completed for 
various reasons. 

UE File – Displays the name of the UE file used during test execution. This may be useful 
when loading results from tests performed on previous days. 

Database Name – Displays the name of the database and the run description of the 
associated test results.  

3.5.3. Detailed Results 

The Detailed Results pane contains additional intermediate results and information 
about a test. In order to view detailed results for a particular test, select the test in the 
Test Results Summary pane by left-clicking anywhere in the test row. Note that detail 
results display for only a subset of test types. If a test does not support detailed results, 
only the test number, name, and description display. 



Chapter Three: Advanced Features | 53 

To copy text from the detailed results pane, select the text with the mouse and press 
Ctrl+C on the keyboard.  

 
Figure 3-18: Test Results Window – Detailed Results 

3.5.4. Graphs 

The Graphs Pane contains graphical tests results. In order to view graphical results for a 
particular test, that test must be selected in the Test Results Summary pane by left-
clicking anywhere in the test row. Note that graphical results appear for only a subset of 
test types. 

To copy and paste graphical results into another application: 

1. Make the graph pane a “floating window” by left-clicking (and holding) the top of the 
pane where it says “Graph”. 

2. While holding the left-click, drag the pane until the gray rectangular outline appears 
float on its own (is not adjacent to any other panes). Release the left click and the 
Graph pane is now floating. 

3. Press Alt+PrtScn on your keyboard to copy the graph. 

4. Paste the graph into other applications such as Microsoft Word or an image editing 
tool. 

TestDrive LTS currently supports two types of graphs. When the test parameter Pass/Fail 
Analysis Type is set to Pseudorange Analysis, the graph in Figure 3-19 displays. This 
graph plots the relative code phase error for each satellite versus the measurement 
sample. 



54 | LTS User Manual 

 
Figure 3-19: Test Results Window – Graphs Pane 

When the Pass/Fail Analysis Type is set to Location Measurement or Success Rate 
Analysis, the scatter plot in Figure 3-20 displays. In this graph, the 2D bias of each 
position fix is plotted relative to the simulated actual position. 

 
Figure 3-20: Graphs Pane – Scatter Plot 

TestDrive version 3.10 introduces new Cumulative Distribution Function (CDF) plots for 
Horizontal Position Error and Response Time, as shown in Figure 3-21. These plots are 
only available in test reports. Statistical data on these calculations are included with the 
plots. 
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Figure 3-21: Test Reports – CDF Plot of Horizontal Error 

3.5.5. Event Log 

The Event Log displays important information that can be useful during test execution. 
There are two types of information that can be viewed in the Event Log pane: Test Events 
and Messages. The Test Events pane displays various occurrences throughout the test, 
such as information points, warnings, and errors. The Messages pane displays the log of 
location services messages transmitted between the SMLC and the UE. 

3.5.5.1 Test Events 

There are three possible types of events displayed in the Test Events pane: 

 Information – Indicates general information such as the time when a test suite 
completed execution. 

 Warnings –Indicates a condition which may or may not be significant to the outcome 
of a test. For example, if a UE fails to respond to a page a warning may occur. This may 
indicate that the UE was still in the process of acquiring service and might not be ready 
to accept incoming calls. 

 Errors –Indicates a condition which will generally cause a test to be labeled 
Undetermined. For example, when a test fails to establish a call to the UE after multiple 
attempts an error may occur. In some cases an error may cause the entire suite to stop 
execution. 

The following is a brief description of the other columns displayed in the Test Events 
pane: 

Test # – Indicates the test number executing when the event was generated. If the event 
occurred before the first test, or after the last test, a test # does not display. 

Description – Indicates specific information about the event. 

Source – Indicates which software module generated the event. This information is 
primarily used for debugging purposes only and may be of little value to the end user. 
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Event#– Indicates a unique number describing the test event. This information is 
primarily used for debugging purposes only and may be of little value to the end user. 

Time – Indicates the date/time when the event occurred. 

 
Figure 3-22: Event Log – Events 

3.5.5.2 Messages 

The Messages pane displays all location services messages that are transmitted 
between the UE and the SMLC during the execution of the test. The left side of the pane 
displays the type of each message as well as its timestamp. Messages transmitted in the 
downlink direction (SMLC to UE) are displayed in blue. Messages transmitted in the 
uplink direction (UE to SMLC) are displayed in green. 

Selecting a specific message under the Messages tab displays the decoded contents on 
the right side of the window for that message, as shown in Figure 3-23. The name of each 
field displays, as well as the length of the field in bits, the value of the field, and a text 
description of the value (if applicable). 

 
Figure 3-23: Event Log – Messages 

3.5.5.3 Table View 

The Table View, shown in Figure 3-24 is only available for TS34.171 and TS51.010 RF 
Conformance tests. It displays each measurement status, the corresponding test 
settings, and result returned by the UE.  
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This view is exported to a TableView.csv file located under the Results folder in the Run 
sub-folder. For details on locating the Results folder, refer to Section 3.5.6 in this 
document. 

The TableView.csv file contains data generated for the tests executed in a particular 
Run. Each Test case data is clearly indicated with a header <Test#> <Test Description> 
<Test Name>. The Table view data follows this header. If a test does not have Table view 
nothing will be logged in the TableView.csv file for that test.  

 
Figure 3-24: Detailed Results – Table View 

3.5.6. Loading Previous Test Results 

The results of suite execution are saved in a Microsoft Access database. TestDrive 
displays these results while you are executing a suite. Review them at a later time by 
selecting File>Open>Results, and select the database. TestDrive displays the different 
suite executions contained in the database. Figure 3-25 shows a sample Open Results 
window. 

 
Figure 3-25: Open Test Results Window 
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The Run Description matches the value as entered in the Execute Automatic Test window 
when the suite was executing. Select a row and click the Load button. TestDrive loads 
the results into a window as they displayed while executing the suite. 

3.5.7. Results Sorting 

You can sort all test results in the Test Results Summary by the following results: 

• Test Number 

• Test Name 

• Test Description 

• Status 

By default, results are sorted by Test Number. You can also sort by any of the above 
results just by clicking on the column header corresponding to that result. When results 
are sorted by a particular result, a “/\” displays in that column header. For a sample of 
the Sorting window, refer to Figure 3-26. 
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Figure 3-26: Test Results Window – Sorting 

NOTE: When you create a report, the results are sorted in the same way they display 
in the Test Results Summary pane. 

3.5.8. Test Result Message Exporting 

The message flow of a test result can be exported into a XML-based file and viewed with 
Internet Explorer. The exported file content includes fields such as, message name, 
protocol type, time stamp, and message decoded details. 

To export a test result message flow, select File>Export Message Log>Current Test/All 
Tests.  

Current Test exports only the selected test result message flow. All Tests exports all tests 
in the same Test Run Results. 

3.5.9. Test Result Compression 

TestDrive LTS possesses a feature that compiles all the results data active on the GUI 
into a compressed (zipped) folder. You can access this feature by selecting File>Zip 
Active Results, or by clicking the Toolbar icon, as shown in Figure 3-27. 

 
Figure 3-27: Accessing the Test Result Zipping Feature 

NOTE: To use this feature, a result must be loaded on the TestDrive GUI. If no result 
is loaded, the icon and the file menu item are disabled.  

Click here to sort by status 
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After selecting Zip Active Results, TestDrive automatically compresses the entire 
Results (.data) folder, including all run information, and places the file in the 
C:\LTSZippedlogs folder.  

The name of the zip file is <result folder name>.zip. For instance, if the result folder 
“Sample.data” is zipped, then the resulting file is named “Sample.data.zip”. 

The compression process takes a few seconds to complete, and depends on the number 
of Runs in a given database. For added convenience, the C:\LTSZippedLogs folder 
automatically opens in Windows Explorer when the process is complete.  

 
Figure 3-28: Destination Folder for Compressed Results Files 

If an error is encountered during the compression process, an Error window displays, as 
shown in Figure 3-29. A debug file is created at C:\ZipDebugLog.txt.  

Report any errors along with the log file to Spirent support.  

 
Figure 3-29: Error Reports During the Zip Process 

3.6. Test Reports 

Test Reports are generated from the current set of test results loaded in application 
memory. You can be print or save reports in a variety of standard file formats including 
Adobe Acrobat (.PDF), Microsoft Excel (.CSV) and Microsoft Word (.DOC). To review 
reports after saving, load the report documents from the appropriate application. For an 
overview of how to generate and manipulate test reports, refer to Section 2.8: Generating 
a Test Report on page 18 of this manual. 

3.7. Configuring Application-Specific Parameters 

You can specify parameters specific to the TestDrive LTS application in one of several 
windows available from the Configure menu.  

You can configure the following types of information: 
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• Instruments  

• Execution Parameters  

• Report Options 

• Message Logging Options  

• Debug Options  

• Run Time Calibration Options 

All information entered into these configuration windows is stored in the system registry 
and is loaded into TestDrive each time you execute the application. 

3.7.1. Execution Parameters 

Before TestDrive can successfully execute tests, you should configure the Execution 
Parameters to comply with your specific conditions. Select Configure>Execution 
Parameters to display the Execution Parameters window, as shown in Figure 3-30. 

 
Figure 3-30: Execution Parameters Window 

Call Setup Parameters – Configuring the Call Setup Parameters appropriately ensures 
successful and efficient call establishment during test execution. If you find that tests 
cannot be completed due to call setup failures, consider adjusting one or more of the 
parameters from the following list. 
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Delay Before Registration (sec) – Some UEs may take time to acquire service from the 
Network Emulator. This parameter causes TestDrive to wait the specified number of 
seconds before attempting to force the UE to register. 

Registration Timeout (sec) – It is possible that the attempt to register the UE may fail. 
This failure may happen for many reasons. Instead of waiting until a registration attempt 
is successful, TestDrive gives the Network Emulator and the UE a specified number of 
seconds to successfully register. When this time has expired and the UE has not 
registered, TestDrive aborts the attempt. 

Call Setup Level (dBm) – Some tests require a very low RF power level (i.e. -100 dBm) at 
the UE. Call setup may fail at such a low level. If this parameter is set to -75 dBm, 
TestDrive ensures that at least -75 dBm is delivered to the UE during call setup. Once the 
call is successfully setup, TestDrive restores the level specified for the test. 

Delay Before 1st Call (sec) – Some UEs take some time to acquire service from the 
Network Emulator. After service is detected, call setup can proceed without much delay. 
This parameter causes TestDrive to wait a specified number of seconds before setting up 
a call to the UE for the first time in a suite. TestDrive will not delay in setting up 
subsequent calls during test execution. 

Call Setup Time (sec) – It is possible the attempt to setup a call will fail. This failure 
may occur for many reasons. Instead of endlessly waiting until a call is successfully 
connected, TestDrive gives the Network Emulator and UE a specified number of seconds 
to establish a call. When this time expired and a call is not established, TestDrive aborts 
the attempt. 

Enable Multiple Call Attempts – TestDrive can make more than one attempt to setup a 
call. To enable this feature, click the checkbox so that it is checked. If this box is 
checked, TestDrive will make more than one attempt to setup a call. If this box is 
unchecked, TestDrive will make one attempt to setup a call. If that attempt fails, 
TestDrive will abort the current test and proceed to the next test. 

Maximum # of Attempts – If the Enable Multiple Call Attempts option is selected, you 
can specify how many times TestDrive should attempt to setup the call. When TestDrive 
has attempted to setup the call the set number of times and the call is still not 
established, it aborts the test and proceeds to the next test. 

Delay Between Attempts (sec) – Use this parameter to have TestDrive wait in between 
call setup attempts. 

User Plane Parameters – User Plane Parameters configures parameters related to call 
control for Network Initiated Sessions of User Plane Protocols: PreSUPL and SUPL. 

Start Network Initiated Sessions Over – Use this parameter to configure the domain on 
which SMS message is to be sent to start Network Initiated Session for User Plane 
protocols: PreSUPL and SUPL. The options are CS-Domain (Circuit Switched Domain) and 
PS-Domain (Packet Switched Domain). 

Auto-Retry Tests – Use this parameter to run the failed or undermined tests a specified 
number of times. 
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When you have finished configuring the Execution Parameters, click OK to save your 
changes and close the window. To abort your changes and close the window, click 
Cancel. 

3.7.2. Message Logging Options 

The Message Logging feature stores messages exchanged in a test in HTML format. By 
default, this feature is disabled. To enable Message Logging; from TestDrive, select 
Configure>Logging Options, as shown in Figure 3-31.  

 
Figure 3-31: Enabling Message Logging 

The Logging Configuration window displays. Select the Log Messages to HTML Format 
option and click OK.  

 
Figure 3-32: Logging Configuration Window 
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3.7.2.1 Location and Directory Structure of Stored Messages 

TestDrive Users 

The HTML messages are stored in the Messages directory of the Run folder. To view 
messages for a test, open the Test<number>.htm file. 

OTA Application Server Users 

In the case of an OTA App Server, logs are stored under the specified directory for logging 
comm.log and other related logs. To view messages, open the Open MainPage.htm file. 

3.7.2.2 Viewing Messages 

When opening MainPage.htm or Test1.htm using Internet Explorer, the Session Log 
displays on the left side of the window. When you select a message the content displays 
on the right side of the window. A Session Log is similar to the TestDrive Message 
window that displays the Session# and messages logged in that session, as shown in 
Figure 3-33.  

 
Figure 3-33: TestDrive Message Window 
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3.7.2.3 PC Configuration 

To view messages properly, you must configure the security settings in your internet 
browser.  

To configure Microsoft Internet Explorer settings to view messages: 

1. Open Internet Explorer and select Tools>Internet Options.  
The Intranet Options window displays, as shown in Figure 3-34. 

 
Figure 3-34: Internet Options Window  

2. Under the Security tab, select Local Intranet, as shown in Figure 3-35.  
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Figure 3-35: Internet Options Window – Security Tab 

3. Click the Custom Level button. 
The Security Settings – Local Intranet Zone window displays, as shown in Figure 
3-36. 

 
Figure 3-36: Security Settings — Local Intranet Zone Window 
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4. Under Reset custom settings, select Medium-Low, as shown in Figure 3-36.  

5. Click OK.  

6. In the Internet Options window, select the Advanced tab, as shown in Figure 3-37. 

 
Figure 3-37: Internet Options Window — Advanced Tab 

7. Under Section Security, select the Allow active content to run in files on My 
Computer option, as shown in Figure 3-37. 
This will enable the ActiveX components required to view the HTML messages. 

To view the messages of a test executed in TestDrive; from the Messages folder, open 
Test#.htm located under the given Run folder of the test database. The Allow Active X 
window displays, as shown in Figure 3-38. Click the Yes button to continue. 

 
Figure 3-38: Active X Warning Window 

Select a message to view the decoded message contents. 
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3.7.3. Debug Options 

In the case that a specific test or other feature fails to perform as expected, it may be 
necessary to enable certain debugging features in TestDrive. Select Configure>Debug 
Options to view this window. 

 
Figure 3-39: Configure Debugging Options Window 

3.7.3.1 Enable Communications Logging 

Enabling this option ensures that all communication transactions between TestDrive and 
the LTS instruments are stored to a text file. The name of the file is comm.log and this 
file is located in the root directory of the TestDrive LTS application (typically C:\Program 
Files\Spirent Communications\TestDrive LTS). 

3.7.4. Run Time Calibration Options 

The Run Time Calibration Option window, shown in Figure 3-40, provides options for 
when to run real-time calibration for test suite execution. The following options are 
available: 

At Beginning of Each Test Suite – Run real-time calibration at the beginning of each 
execution. 

Interval (Hours) –Enter the amount of time between each run time calibration. The valid 
value can be between 1 and 72 hours. 

 
Figure 3-40: Configure Run Time Calibration Window 

3.7.5. OTA Testing Setup 

Under the Configure menu, select the OTA Testing option to open the OTA Testing 
Configuration window, shown in Figure 3-41. These parameters need to be correct to run 
OTA tests correctly. 
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Figure 3-41: OTA Testing Configuration Window 

GPS Signal – Allows you to specify the Horizontal or Vertical Polarized Path-Loss of the 
anechoic chamber. 

GSM/WCDMA Signal – Allows you to specify the type of supported cellular link. Refer to 
the LTS-OTA Integration Application Note for more information on setting the cellular link 
for OTA testing. 

Manual Step Attenuator – Allows you to specify the loss parameters of the MSA used to 
run tests. If you opt not to use the Manual Step Attenuator, deselect this option (refer to 
the GPS Power Level Calibration Factor). The default values entered are provided by the 
factory, and can be used while the system is in calibration. 

GPS Power Level Calibration Factor – Allows you to specify any additional loss in the 
GPS path due to additional cables and RF Level uncertainty at the GSS6560. The default 
value entered is provided by the factory, and can be used as is while the system is in 
calibration. This feature also allows you to use any additional attenuator instead of the 
Manual Step Attenuator. 

3.8. Parameter Sweep 

The Parameter Sweep feature allows you to insert a set of tests where only a single 
parameter value changes between from test to test and the rest of the test parameters 
remain the same. This single parameter value is set to a range of values between a 
specified start value and stop value. You can also specify the resolution of the increment 
between steps. 

To sweep a test parameter: 



70 | LTS User Manual 

1. Select the desired parameter (choose only numeric parameters). 

2. Click the Parameter Sweep button  on the toolbar or select Edit>Parameter 
Sweep. The Parameter Sweep window shown in Figure 3-42 displays. 

3. Specify the Start Value, Stop Value and Increment for the parameter. 

4. Enable the Graph Sweep Results option if you want to output the results of the 
parameter sweep to a graph. 

5. Click the Insert Tests button. The number of tests specified in the window display 
below the test of the selected parameter.  

NOTE: Any test in the section in which new tests are inserted will be deleted. Only 
enabled numeric test parameters can be swept. Read-only and disabled parameters 
cannot be swept. 

 
Figure 3-42: Parameter Sweep Window 

Parameter Name –The name of the selected parameter. 

Start Value – The value of the parameter in the first test inserted into the suite. 

Stop Value – Specifies the value of this parameter in the last test inserted into the suite. 
The actual value of the parameter in the last test will be less than or equal to the Stop 
Value, depending on the Start Value and the Increment. 

Increment – Represents the difference in the value of this parameter between each test 
inserted into the suite.  

Parameter Range – The valid range of values that this parameter can have. 

# of tests to be created – The actual number of tests inserted in the suite as a result of 
the current parameter sweep settings. 

Insert Tests – Inserts the resulting tests in the suite. 
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Graph Sweep Results – Enables or disables the creation of graphical results based on 
this parameter sweep. 

Use this window to configure the Start Value, Stop Value and Increment of the parameter 
you want to sweep. The Start Value and Stop Value have to be within the valid range of 
the selected parameter. If any of the values are out of this range, a red “X” displays next 
to the parameter. The Increment value must be a positive number regardless of the 
direction of the sweep. If the Increment is set to a negative number, a red “X” displays 
next to the value. If any of the parameters are out of range or you have not specified all 
of the settings, the Insert Tests button will not be available. 

3.9. Graphical Sweep Results 

If the Graph Sweep Results option is checked, a graphical representation of the sweep is 
created after all tests are completed. You can select which test results to graph by 
selecting from a list of all applicable parameters in the Parameter Sweep dialog box. 
Once all tests pertaining to the parameter sweep are executed, a new test (of type 
“Sweep to Graph”) is created for each selected test result. To view the graphical results 
of the sweep, left-click on the Sweep to Graph test in the Test Results Summary pane. 
Numerical results display in the Detailed Results pane and graphical results display in 
the Graphs pane. 

 
Figure 3-43: Graphical Sweep Results Window 
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3.10. System Calibration 

TestDrive LTS includes a semi-automated calibration procedure to achieve high accuracy 
for power levels at various points in the system. This procedure is available in the 8100-
A500, A600, and 8100-B series platforms. The procedure measures the insertion loss 
through various signal paths in the system and stores this information in a Microsoft 
Access Database. The following sub-sections describe how to execute the calibration 
procedure as well as how to use the calibration data to attain accurate power levels. 

All LTS systems are calibrated prior to shipment. We recommend that you calibrate each 
system when first received, and then once every six months thereafter, or whenever new 
cables are introduced into the system. 

3.10.1. Equipment Requirements 

The following minimum equipment and accessories are required to perform the LTS 
Calibration Procedure: 

• Agilent E4417A or E4418A Power Meter with one or two power sensors 

• Spirent SR5048 or SR8068 or SR8048+SR8068 combination Test Configuration Unit 

• Agilent 3499A/B Switch/Control System 

• Spirent GSS6560 GPS Simulator/Spirent STR4500 GPS Simulator/Spirent GSS6700 
GPS Simulator/Spirent GSS8000 GPS Simulator 

• Spirent SR3420 Wireless Network Emulator 

• Spirent E2010s Broadband Wireless Test Set 

• Spirent SR3452 CDMA Network Emulator 

• Agilent 8960 Wireless Communications Test Set 

• One N-type connector (female-female) 

• One N-type 50-ohm termination 

• N-type Torque Wrench 

• Full set of RF cables provided with the system 

3.10.2. Executing the Calibration Procedure 

To execute the System Calibration procedure, select Execute>Calibration. The LTS 
Calibration Wizard window with SR5048 displays, as shown in Figure 3-44. The 
Calibration Wizard walks you through the entire calibration procedure. During the 
calibration procedure, it is necessary to re-configure some of the RF cables. The entire 
procedure takes approximately 20~40 minutes to complete. Note that the calibration 
procedures for the E4417A and E4416A power meters are different. Also, the Calibration 
Wizard with SR8068 or SR8048+SR8068 combination is very similar to Calibration with 
SR5048, just RF cable pictures different.   
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Step #1 – Initialization 

The window in Figure 3-44 displays setup information important to complete prior to 
executing the calibration procedure. The instructions indicate how to connect various RF 
cables in the system. The setup described here is identical to the instructions on the 
system cabling poster. 

After clicking the Next button, TestDrive attempts to connect to all required equipment. If 
TestDrive cannot communicate with any of the required equipment, an error message 
displays. 

 
Figure 3-44: Calibration Wizard – Initialization 

NOTE: Use the N-type and SMA-type Torque Wrenches when removing and 
tightening cables. 

Step #2 – Calibrating Power Meter Sensor A 

Connect the Power Meter Sensor on Channel A to the POWER REF port on the power 
meter.  

After clicking the Next button, TestDrive commands the power meter to perform a zero 
and calibration on the sensor. 
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Figure 3-45: Calibration Wizard – Power Meter Sensor A 

Step #3 – Calibrating Power Meter Sensor B (optional for systems that have two 
power sensors) 

Connect the Power Meter Sensor on Channel B to the POWER REF port on the power 
meter.  

After clicking the Next button, TestDrive commands the power meter to perform a zero 
and calibration on the sensor. 

 
Figure 3-46: Calibration Wizard – Power Meter Sensor B 

Step #4 – Calibrating Power Levels to the End of Cable C2 (optional for SR5048 and 
SR8068 units) 

Connect the Power Meter Sensor on Channel B to the end of cable C2 using the “N”-
type barrel adapter.  
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After clicking the Next button, TestDrive starts performing measurements of various 
signal paths that terminate at the end of cable C2. Measurements are swept across 
frequencies. 

 
Figure 3-47: Calibration Wizard – C2 Power Levels 

Step #4a – Calibrating Power Levels to the End of Cable C1B (optional for 
SR8048+SR8068 combination) 

Connect the Power Meter Sensor to the end of cable C1B using the “N”-type barrel 
adapter, as shown in Figure 3-48.  

Click the Next button. TestDrive now starts performing measurements of various signal 
paths that terminate at the end of cable C1B. Measurements are swept across 
frequencies. 
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Figure 3-48: Calibration Wizard – C1B Power Levels 

Step #5 – Calibrating Power Levels to the End of Cable C2B (optional for 
SR8048+SR8068 combination with E2010s selected) 

Connect the Power Meter Sensor to the end of cable C2B using the “N”-type barrel 
adapter.  

Click the Next button. TestDrive now starts performing measurements of various signal 
paths that terminate at the end of cable C2B. Measurements are swept across 
frequencies. 

 
Figure 3-49: Calibration Wizard – C2B Power Levels 
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Step #6 – Calibrating Power Levels to the End of Cable C18 (optional for SR5048 
and SR8068 units) 

Connect the Power Meter Sensor to the end of cable C18 using the “N”-type barrel 
adapter. If your system has one power sensor, the software instructs you to use  
Channel A; otherwise, use Channel B. 

Click the Next button. TestDrive now starts performing measurements of various signal 
paths that terminate at the end of cable C18.  

 
Figure 3-50: Calibration Wizard – C18 Power Levels 

Step #6a – Calibrating Power Levels to the End of Cable C18B (optional for 
SR8048+SR8068 combination) 

Connect the Power Meter Sensor to the end of cable C18B using the “N”-type barrel 
adapter. If your system has one power sensor, the software instructs you to use  
Channel A; otherwise, use Channel B. 

Click the Next button. TestDrive now starts performing measurements of various signal 
paths that terminate at the end of cable C18B.  
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Figure 3-51: Calibration Wizard – C18B Power Levels 

Step #7 – Calibrating Power Levels to the Port of P1 (optional for SR5048 or 
SR8068) 

Connect the Power Meter Sensor to the Port of P1 using the “N”-type barrel adapter. If 
your system has one power sensor, the software instructs you to use Channel A, if not, 
use Channel B. 

Click the Next button. TestDrive now starts performing measurements of various signal 
paths that terminate at the Port of P1. 

 
Figure 3-52: Calibration Wizard – P1 Power Levels 
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Step #7a – Calibrating Power Levels to the Port of P18 (optional for 
SR8048+SR8068 combination) 

Connect the Power Meter Sensor to the Port of P18 using the “N”-type barrel adapter. If 
your system has one power sensor, the software instructs you to use Channel A; 
otherwise, use Channel B. 

Click the Next button. TestDrive now starts performing measurements of various signal 
paths that terminate at the Port of P18. 

 
Figure 3-53: Calibration Wizard – P18 Power Levels 

Step #8 – Post-Calibration Setup  

Reconnect the system for use during normal operation.  

Click the Next button. TestDrive now calculates and displays the calibration data in 
tabular and graphical format. 



80 | LTS User Manual 

 
Figure 3-54: Calibration Wizard – Confirmation Window 

Step #9 – Viewing the Calibration Data 

After completing the calibration, the TestDrive Calibration Wizard displays the data in 
tabular and graphical format as shown in Figure 3-55.  

This window allows you to browse through the calibration data for various signal paths 
by selecting the Path #. A text description of the path is provided next to the path 
number. 

To track system drift over time, you can set TestDrive to record calibration data as a 
Reference Calibration by clicking the Store as Reference button. It is recommended that 
you store the calibration data as a reference calibration the first time the system is 
assembled, and any time a major component in the system changes. Successive 
calibration runs are stored as the active calibration. Display Calibration Drift by changing 
the Data Set to Drift. You can view a complete calibration history in the Calibration 
History.mdb database. 
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Figure 3-55: Calibration Data Window 

3.10.3. Theory of Operation 

The TestDrive system calibration procedure provides highly accurate GSM, W-CDMA, 
WCDMA-HS (SR3420) and GPS power levels to the UE during normal test execution. It 
measures the power level of the various instruments at the output of the test system 
(refer to Figure 3-56). The GSM/WCDMA/WCDMA-HS power levels are calibrated to the 
end of cable C2; the GPS power level is calibrated to the end of cables C2 (for single port 
UEs), and cable C18 (for multiple port UEs).  

 
Figure 3-56: Instrument Power Level Diagram 
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During calibration, TestDrive takes power level measurements at the ends of cables C2 
and C18 using the Agilent power meter. These measurements calculate a pseudo 
insertion loss value from the transmitting instrument to the end of the associated cable. 
For example, if the SR3420 WCDMA network emulator is set to transmit at –20dBm, the 
pseudo insertion loss is calculated = -20dBm – power meter measurement. The power 
levels and frequency range of measurements during calibration are indicated in the table 
below. 

Technology Transmit Power Level Frequency Range(s) 

GSM -20 dBm 869.5 – 893.5MHz (8MHz resolution) 
935.5 – 958.5MHz (8MHz resolution) 
1810 – 1870MHz (20MHz resolution) 
1940 – 1980 MHz (20MHz resolution) 

W-CDMA-HS -20 dBm 1940 – 1980 MHz (20MHz resolution) 
2120 – 2160MHz (20MHz resolution) 

GPS -43 dBm* 1575.4148 MHz 

*Actual maximum GPS transmit level varies slightly from instrument to instrument. 

In addition to taking measurements at the end of cables C2 and C18, TestDrive also 
measures the power level of the various instruments at the TAS5048 port P1. This data 
detects and compensates for any power level drift after the calibration procedure is 
performed. During test suite execution, the power level of each signal source is 
measured to compare against data measured at the time of calibration. 

At run-time, pre-stored calibration data initializes power levels on various instruments. 
The formula for calculating the transmit level of the GSM, WCDMA and WCDMA-HS 
network emulators is shown below. 

PowerTX = Powerdes + PathIL + Powerdrift 

 where 

  PowerTX = transmit power of the desired instrument 

  Powerdes = desired power level at the output of the LTS 

system 

PathIL = “pseudo” insertion loss measured during calibration for the 
specified signal path. A linear interpolation algorithm is used to 
determine this value as a function of the transmit frequency. 

Powerdrift = power level drift for the transmitter (measured at the 
beginning of suite execution). 

Calculation of the GPS transmit level is a little more complicated. There are two output 
ports on the GPS simulator: RF Output on the front panel and CAL output on the rear 
panel. There is a fixed attenuator between the CAL output and the RF output. In LTS, the 
CAL output is connected to the TAS5048. Inside the TAS5048, a programmable 
attenuator controls the GPS power level delivered to the UE. 
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The formula for calculating the transmit level of the GPS simulator is shown below. 

PowerTX = Powerdes + PathIL + Poweratten + Powerdrift - RFOF 

 where 

  PowerTX = transmit power of the GPS simulator 
  Powerdes = desired power level at the output of the LTS  
  system 

PathIL = pseudo insertion loss measured during calibration for the 
specified signal path. A linear interpolation algorithm is used to 
determine this value as a function of the transmit frequency. This 
insertion loss assumes a value of zero attenuation in the TAS5048. 

Poweratten = the level of attenuation applied in the TAS5048. 

Powerdrift = power level drift for the transmitter (measured at the 
beginning of suite execution). 

RFOF = the level of fixed attenuation between the RF Output and CAL 
output on the GPS simulator. This is typically around 60 dB. 

3.10.4. Error Conditions 

During execution of the calibration procedure, it is possible that there are errors reported 
by TestDrive.  

Typical errors that could occur during execution include: 

• LTS system is missing required equipment to perform the calibration procedure. In 
this case, you are prompted to change the system configuration options by using the 
Instrument Configuration window in TestDrive LTS. 

• TestDrive LTS is unable to communicate with all required equipment. If this happens, 
refer to the appropriate Setup Guide to verify all equipment connections are correct. 

• TestDrive LTS detects incorrect hardware and/or firmware options installed in the 
system. 

• TestDrive detects measurements out of range during calibration. This could occur for 
a number of reasons including: 

 Incorrect cable connections. 

 Loose cable connections (please remember to use the torque wrench when 
connecting RF cables). 

 Equipment slightly out of tolerance. 

 Equipment malfunctioning. 

If an out-of-range measurement occurs, you are warned and given the option to cancel, 
retry, or ignore the warning. Retrying may be useful if the cables are connected 
incorrectly.  

3.10.5. Canceling the Calibration 

At the bottom of the Calibration Wizard window is a Cancel button. Clicking this button 
displays the following warning shown in Figure 3-57. 
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Figure 3-57: Calibration Cancellation Warning 

3.11. Using LTS to Test SUPL-Enabled Terminals 

LTS provides several suites of test cases designed to test SUPL Enabled Terminals (SETs) 
supporting SUPL 1.0 and/or SUPL 2.0. For performance-based testing, Spirent custom 
minimum performance test cases can be used to test SETs. Test suites are provided to 
support W-CDMA, GPRS, and LTE capable devices; as well as stand-alone A-GPS chipsets 
(within LTS-ADS configuration for SUPL 1.0 only). SUPL 1.0 protocol testing can be 
performed using Spirent OMA-SUPL-ETS test packs that emulate the OMA Enabler Test 
Specification for SUPL 1.0. SUPL 2.0 protocol testing can be performed using Spirent 
OMA-SUPL2.0-ETS test packs that emulate the TTCN-3 based OMA Enabler Test 
Specification for SUPL 2.0. This section provides an overview of SUPL testing on the LTS 
system, including some key configuration concepts. 

LTS supports SET-initiated and Network-initiated Proxy Mode call flows for SUPL 1.0 and 
SUPL 2.0. When testing a SET for the first time, we recommend you start with SET-
initiated call flows. This requires the SET to be configured with a fully qualified domain 
name (www.spirent-lcs.com) of the SUPL server to reach a specific IP address. It is not 
possible to change the target IP address, but it is possible to change the FQDN by 
changing a test parameter in the test case adding an entry to the DNS server. The SLP 
port number on the SET should match the test parameter specified in the TestDrive test 
case. 

During a SET-initiated positioning session, the UE is stimulated to start a session 
(typically through the SET user interface). At the beginning of the session, the UE 
establishes a WCDMA, GPRS, or LTE data call. In the case of a LTS-ADS system, a simple 
socket connection. If the UE is using an FQDN to locate the SUPL server, the IP address of 
the SUPL server is obtained from the DNS server. After the SUPL server IP address is 
determined, a socket connection is established from the UE to the SUPL server and the 
SUPL_START message is delivered. Finally, a normal SET-Initiated session begins. 
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Prior to performing a Network-Initiated SUPL session, it is necessary to ensure that the 
“Content Type” and “Application ID” parameters specified in the test case match the 
expected settings on the SET. If these parameters are not set correctly, it will likely result 
in a failure to initiate a SUPL session correctly. It is also necessary to configure the “SUPL 
Initiation Method” to SMS or WAP_PUSH. During a Network-Initiated positioning 
session, a SUPL_INIT message is transmitted through SMS to the SET (or through the 
ADS router in LTS-ADS). If the system configuration matches the SET configuration, the 
SET responds to the SUPL_INIT message by setting up a data call and establishing a 
socket connection. After this, the normal Network-Initiated session continues. 

By default, all SUPL tests are performed with SUPL security enabled. To prepare for 
testing secure SUPL sessions, install the spirentroot.cer (PEM format) or the 
spirentroot.der onto the SET (NOTE: Some SETs support only the DER format of the root 
certificate. In this case it is not necessary to install the CER file). Set the test parameter 
“Turn on Secure Session = Yes” in TestDrive, and possible TLS parameters to match the 
SET settings. Finally make sure that clock on UE shows correct date, day, month, and 
year. If this is not set properly, the secure session may fail to establish.  

As of LTS version 6.30, the following cipher suites are supported: 

• TLS_RSA_ WITH_NULL_MD5  

• TLS_RSA_EXPORT_ WITH_RC4_40_MD5  

• TLS_RSA_ WITH_RC4_SHA1  

• TLS_RSA_ WITH_RC4_MD5  

• TLS_RSA_ WITH_3DES_EDE_CBC_SHA1  

• TLS_RSA_ WITH_AES_128_CBC_SHA1  

• TLS_RSA_ WITH_AES_256_CBC_SHA1  

• TLS_RSA_ WITH_CAMELLIA_128_CBC_SHA1  

• TLS_RSA_ WITH_CAMELLIA_256_CBC_SHA1  

The recommended suites are: 

• TLS_RSA_ WITH_AES_128_CBC_SHA1  

• TLS_RSA_ WITH_3DES_EDE_CBC_SHA1 

• The above are required by 3GPP and OMA specifications.  

SUPL 2.0 protocol test cases based on the OMA SUPL 2.0 Enabler Test specification are 
offered as TTCN-3 scripts. Refer to the “SUPL V2 0 TTCN3 Install and User Guide" and 
"Secure User Plane Location (SUPL) 2.0 Reference Guide" for more details. 



4. Technical Specifications 

4.1. Satellite Simulator Specifications 

The following table provides a selected list of GPS performance specifications within the 
LTS system. For a complete list of specifications for the GPS simulator, refer to the 
Spirent Signal Generator Hardware Manual (DGP00703AAA).  

The following specifications apply to configurations that include either the STR4500 or 
GSS6560 simulators. 

Parameter Platform(s) Specification 

Number of GPS signal sources ALL 12 channels (simultaneous) 

Nominal carrier frequency ALL 1575.42 MHz 

Multipath generation ALL Yes 

Atmospheric effects ALL Yes 

Signal Level Range  A400, A750 Primary Output:  -115 dBm to -150 dBm 
Secondary Output: -55 dBm to -90 dBm 

 A500, A600, 
B-Series 

-75 dBm to -170 dBm 

Signal Level Resolution ALL 0.1 dB 

Absolute Signal Level Accuracy A400, A750 +/- 1.0 dB (RSS), +/- 2.0 dB Max 

 A500, A600, 
B-Series 

+/- 0.81 dB Max 

Relative Signal Level Accuracy 
(between satellites during a 
single simulation) 

ALL +/- 0.1 dB 

Simulated Position Error ALL +/- 2.5 cm 

The following specifications apply to configurations that include a GSS6700 simulator. 

Parameter Platform(s) Specification 

Number of GPS signal sources ALL 12 channels (simultaneous) 

Number of GLONASS signal 
sources 

ALL 12 channels (simultaneous) 

Nominal GPS carrier frequency ALL 1575.42 MHz 

GLONASS center frequency ALL 1602.00 MHz 

GNSS Multipath generation ALL Yes 

GNSS Atmospheric effects ALL Yes 
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Parameter Platform(s) Specification 

Signal Level Range  A400, A750 GPS Signal 
Primary Output:  -115 dBm to -150 dBm 
Secondary Output: -55 dBm to -90 dBm 
GLONASS Signal 
Primary Output:  -116 dBm to -151 dBm 
Secondary Output: -56 dBm to -91 dBm 

 A500, A600, 
B-Series 

-75 dBm to -170 dBm 

Signal Level Resolution ALL 0.1 dB 

Absolute Signal Level Accuracy A400, A750 +/- 0.5 dB  

 A500, A600, 
B-Series 

+/- 0.81 dB Max 

Simulated Position Error ALL +/- 2.5 cm 

The following specifications apply to configurations that include a GSS8000 simulator. 

Parameter Platform(s) Specification 

Number of GPS signal sources ALL 12 channels (simultaneous) 

Number of GLONASS signal 
sources 

ALL 12 channels (simultaneous) 

Nominal GPS carrier frequency ALL 1575.42 MHz 

GLONASS center frequency ALL 1602.00 MHz 

GNSS Multipath generation ALL Yes 

GNSS Atmospheric effects ALL Yes 

Signal Level Range  A400, A750 GPS Signal 
Primary Output:  -110 dBm to -170 dBm 
Secondary Output: -60 dBm to -120 dBm 
GLONASS Signal 
Primary Output:  -111 dBm to -171 dBm 
Secondary Output: -61 dBm to -121 dBm 

 A500, A600, 
B-Series 

-75 dBm to -170 dBm 

Signal Level Resolution ALL 0.1 dB 

Absolute Signal Level Accuracy A400, A750 +/- 0.5 dB  

 A500, A600, 
B-Series 

+/- 0.81 dB Max 

Simulated Position Error ALL +/- 2.5 cm 
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4.2. Network Emulation Specifications 

The following specifications apply to all platforms except 8100-A400. 

Parameter Specification 

WCDMA Frequency Bands I, II, III, IV, V, VI, VIII, IX,XI 

GSM Frequency Bands 850, 900, 1850, 1900 

Output Level Range -50 to -110 dBm 

Output Level Resolution 0.1 dB 

Output Level Accuracy +/- 1.0 dB max 

4.3. Timing and Synchronization 

The following specifications apply to 3GPP TS 34.171 and 3GPP TS 51.010 minimum 
performance test cases ONLY. 

Parameter Specification 

Coarse Time Assistance Accuracy +/- 50ms max, +/- 12ms typical 

Fine Time Assistance Accuracy +/- 1.0 µs max, +/- 0.4 µs typical 

Response Time Accuracy 
(applies to TTFF test cases) 

+/- 100 ms max 

Differential Response Time Accuracy 
(applies to moving scenario test 
case only) 

+/- 100 ms max 

4.4. SMLC / SLP Emulation 

Parameter Specification 

Protocols RRLP, RRC, SUPL V1.0 (RRLP, RRC), SUPL V2.0 (RRLP, RRC, 
LPP), Pre-SUPL 

Positioning Methods (control-plane) MS-Based, MS-Assisted, Autonomous, Cell-ID 

Positioning Methods (user-plane) MS-Based, MS-Assisted, Autonomous, ECID, No Position, 
OTDOA 

Call Flows (control-plane) NI-LR, MT-LR, MO-LR 

Call Flows (user-plane) Network-Initiated Immediate, Network-Initiated Periodic,  
SET-Initiated Immediate, SET-Initiated Periodic, 
Emergency Location 



Chapter Six: Technical Specifications |-89 

4.5. GPS Assistance Data Elements 

Parameter Specification 

Reference Time Yes (11 parameters) 

Reference Location Yes (15 parameters) 

DGPS Corrections Yes 

Navigation Model Yes 

Ionospheric Model Yes 

UTC Model Yes 

Almanac Yes 

Acquisition Assistance Yes (18 parameters) 

Real-time Integrity Yes 

4.6. Interfaces 

Parameter Platform Specification 

GPS Interfaces A400, A750 GSS6560/GSS8000: 
RF Output (front): N-type connector 
MON/CAL (rear): N-type connector 
GSS6700: 
RF Output (front): N-type connector 
MON/CAL (rear): SMA-type connector 

 A500, A600,  
B-Series 

GPS Out 2: N-type connector 
Use this interface for handsets with 
separate connectors for GPS and cellular 
signals. 
SR5048 P2:  N-type connector 
Use this interface for handsets with a single 
connector for combined GPS/cellular 
signals. 

GSM/WCDMA Interfaces A750 RF I/O (duplex): N-type connector 
Downlink RF 1: SMA-type connector 
Downlink RF 2: SMA-type connector 

 A500, A600 SR5048 P2:  N-type connector 

LTE Interfaces B750 TX1/RX1 (primary):  N-type connector 
TX2 (secondary):  N-type connector 

 B500, B600 SR8068 P5: N-type connector for LTE 
primary and duplex connection 
E2010 TX2 (secondary):  N-type connector 

Control Interfaces A400 9-PIN DSUB connector for DUT that require 
serial communications interface 
Ethernet port for DUT that require TCP/IP 
interface 
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4.7. Environmental 

Parameter Platform(s) Specification 

Operating Temperature ALL 15 – 29 °C 

Dimensions A500, A750, B750 57 x 23 x 37 inches  
(144.78 x 58.42 x 93.98 cm) 

 A600, B500, B600 77 X 23 7 37 inches  
(195.58 x 58.42 x 93.98 cm) 

Power Consumption A750 1000 to 1050 Watts 
Continuous 

 A400 200 to 250 Watts Continuous 

 A500 950 to 1000 Watts Continuous 

 A600 1400 to 1450 Watts 
Continuous 

 B750 
B750 with CDMA 
B750 with UMTS 

Up to 1050 Watts Continuous 
Up to 1300 Watts Continuous 
Up to 1425 Watts Continuous 

 B500 Up to 2100 Watts Continuous 



5. Appendix: USIM Configurations 

Some OMA-SUPL-ETS test cases require a special USIM card. All new LTS systems supply 
three configurations of USIM cards. To easily identify the USIM cards, they have been 
marked with a colored DOT. To identify the USIM configuration, follow the color code 
shown below. 

USIM with a WHITE or GREEN dot is the Default USIM. This can be used for all the tests 
EXCEPT for a few OMA-SUPL-ETS test cases. These exceptions are defined below. 

  
USIM with a BROWN dot is used for SUPL-1.0-con023 Test 2, SUPL-1.0-con023 Test 3, 
SUPL-1.0-con023 Test 4, and SUPL-1.0-con023 Test 5 Part 1.  

 
USIM with RED dot is used for SUPL-1.0-con023 Test 5 Part 2.  



6. Using LTS with Windows 7 

6.1. Upgrade/Downgrade 

1. LTS 6.20/PTLS 3.80 or later can be installed in a Windows 7 Controller PC. Prior 
versions are now Windows 7 compatible.  

2. The upgrade/downgrade between LTS 6.20/PTLS 3.80 and LTS 6.10/PTLS 3.70 and 
earlier versions are only supported in Windows XP. 

6.2. Software Configuration 

6.2.1. Setting PosApp Properties 

1. Right-click the PosApp.exe file in the Windows Desktop and select Properties from 
the menu. 

2. Under the Compatibility tab, as shown in Figure 6-1, enable the Run this program in 
compatibility mode for option. Select Windows 2000 from the drop-down menu. 

3. Enable the Run this program as an administrator option. 

 
Figure 6-1: PosApp Properties – Compatibility Tab 
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4. Ensure that no other options are selected. 

5. Click the Change settings for all users button. 
The Compatibility for All Users window displays, as shown in Figure 6-2. 

6. Enable the Run this program in compatibility mode for option. Select Windows 
2000 from the drop-down menu. 

7. Enable the Run this program as an administrator option. 

 
Figure 6-2: PosApp Properties – Compatibility for All Users Options 

8. Click OK to save the settings. 

6.2.2. Setting TestDrive LTS Properties 

1. Right-click the TestDrive.exe file in the Windows Desktop and select Properties from 
the menu. 

2. Under the Compatibility tab, shown in Figure 6-3, enable the Run this program as 
an administrator option. 
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Figure 6-3: TestDrive LTS Properties – Compatibility Tab 

3. Ensure that no other options are selected. 

4. Click the Change settings for all users button. 
The Compatibility for All Users window displays, as shown in Figure 6-4. 

5. Enable the Run this program as an administrator option. 
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Figure 6-4: TestDrive LTS Properties – Compatibility for All Users Options 

6. Click OK to save the settings. 

NOTE: The User Account Control window shown in Figure 6-5 displays when 
starting the TestDriveLTS.exe file. Click Yes to proceed.  

 

 
Figure 6-5: User Account Control Window 
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6.2.3. Setting OTA Application Server Properties 

1. Right click the Spirent OTA Application Server.exe file in Windows Desktop and 
select Properties from the menu. 

2. Under the Compatibility tab shown in Figure 6-6, enable the Run this program as an 
administrator option. 

 
Figure 6-6: OTA App Server Properties – Compatibility Tab 

3. Ensure that no other options are selected. 

4. Click the Change settings for all users button. 
The Compatibility for All Users window displays, as shown in Figure 6-7. 

5. Enable the Run this program as an administrator option. 
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Figure 6-7: OTA App Server Properties – Compatibility for All Users Options 

6. Click OK to save the settings. 

NOTE: The User Account Control window shown in Figure 6-8 displays when 
starting the OTAServerWin.exe file. Click Yes to proceed.  

 

 
Figure 6-8: User Account Control Window 
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6.2.4. Setting TTworkbenchExpress Properties 

1. Right click the ttworkbench.exe file in Windows Desktop and select Properties from 
the menu. 

2. Under the Compatibility tab shown in Figure 6-9, enable the Run this program as an 
administrator option. 

 
Figure 6-9: TTworkbenchExpress Properties – Compatibility Tab 

1. Ensure that no other options are selected. 

2. Click the Change settings for all users button. 
The Compatibility for All Users window displays, as shown in Figure 6-10. 

3. Enable the Run this program as an administrator option. 
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Figure 6-10: TTworkbenchExpress Properties – Compatibility for All Users Options 

4. Click OK to save the settings. 

NOTE: The User Account Control window shown in Figure 6-11 displays when 
starting the ttworkbench.exe file. Click Yes to proceed.  

 

 
Figure 6-11: User Account Control Window 
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